Difference between revisions of "Gentoo"

From LXDE.org
Jump to: navigation, search
(Correction of the link to the LXDE Gentoo project at the end of the article)
(Runlevel is a word in itself)
 
(3 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
== Installing LXDE ==
 
== Installing LXDE ==
 
=== Using <tt>emerge</tt> ===
 
=== Using <tt>emerge</tt> ===
There are several packages for lxde. You can install all of them at once
+
There are several packages for lxde. You can install all of them at once by emerging the lxde-meta meta package:
by emerging the lxde-meta meta package:
 
 
  emerge -avt lxde-base/lxde-meta
 
  emerge -avt lxde-base/lxde-meta
  
Line 33: Line 32:
 
  rc-update add xdm default
 
  rc-update add xdm default
  
== External link ==
+
== External links ==
* [https://wiki.gentoo.org/wiki/Project:LXDE LXDE Gentoo Project]: official project at gentoo.org working on LXDE for gentoo
+
* [https://wiki.gentoo.org/wiki/Project:LXDE LXDE Gentoo Project]: official project at gentoo.org working on LXDE for Gentoo
  
 
[[Category:LXDE]]
 
[[Category:LXDE]]

Latest revision as of 20:02, 18 September 2019

Installing LXDE

Using emerge

There are several packages for lxde. You can install all of them at once by emerging the lxde-meta meta package:

emerge -avt lxde-base/lxde-meta

Installing LXDM

LXDM is not yet part of lxde-base/lxde-meta. To install it anyway, emerge it seperately:

emerge -avt lxde-base/lxdm

Using paludis

Unmask some packages:

cat >> /etc/paludis/keywords.conf << EOF
lxde-base/lxde-common ~x86
lxde-base/lxsession ~x86
lxde-base/lxpanel ~x86
x11-misc/pcmanfm ~x86
media-gfx/gpicview ~x86
EOF

There are several packages for lxde, you may install all of them at once with the following command:

paludis -i lxde-common lxsession lxde-base/lxpanel pcmanfm gpicview openbox -p

Running LXDE

If you use XDM, GDM or something like that LXDE will be listed as you log in. If you use startx, add 'exec startlxde' to your ~/.xinitrc

Using LXDM

Edit /etc/conf.d/xdm and set

DISPLAYMANAGER="lxdm"

Then add xdm to the default runlevel if it isn't already:

rc-update add xdm default

External links