General Information: Różnice pomiędzy wersjami

Z LXDE.org
Skocz do: nawigacja, szukaj
(Nowa strona: ==Wymaganie systemowe== W porównaniu do innych współczesnych środowisk graficznych, wymagania LXDE są dosyć niskie. Komputer osobisty wyprodukowany w 1999 powinien dobrze sobie z ...)
 
m
 
Linia 28: Linia 28:
  
 
[[Category:LXDE]]
 
[[Category:LXDE]]
[[Category:LXDE System Requirements]]
+
[[Category:Wymagania]]

Aktualna wersja na dzień 21:13, 13 cze 2011

Wymaganie systemowe

W porównaniu do innych współczesnych środowisk graficznych, wymagania LXDE są dosyć niskie. Komputer osobisty wyprodukowany w 1999 powinien dobrze sobie z nim poradzić.

Kompatybilność

LXDE można uruchomić na każdym systemie POSIX z zainstalowanym graficznym systemem X11. Aktualnie główną wspieraną platformą jest Linux. FreeBSD jest także testowany. Inne Unix'o podobne systemy powinny być całkiem dobrze wspierana, choć nie są dobrze przetestowane. Tak więc pomoc w tej kwestii jest potrzebna. Jeśli udało ci się pomyślnie zainstalować LXDE na innych systemach lub stworzyłeś jakieś poprawki dla nich, proszę umieścić je na na naszym trackerze .

Opcje dostępne tylko dla systemu Linux (Opcjonalnie, mogą być wyłączone)

Niektóre właściwości LXDE są specyficzne tylko dla systemów Linux. Możesz je wyłączyć w trakcie kompilacji. Tak więc LXDE powinien być kompilowalny na innych systemach. Sprawdź ./configure --help żeby dowiedzieć się więcej o dostępnych opcjach.

PCManFM - menedżer plików

  • DBus i HAL (warstwa abstrakcji sprzętowej): HAL jest używany do montowania i zarządzania przenośnymi urządzeniami (twarde dyski, cd/dvd, pamięci flash).
    • Jest to opcjonalne i można to wyłączyć. Jednakże wtedy PCManFM straci możliwość montowania urządzeń. (Od wersji 6.0, HAL jest także dostępny dla FreeBSD)

LXPanel - panel pulpitu

  • wtyczka netstat: Monitor połączeń internetowych a tak że daje łatwy dostęp do bezprzewodowych połączeń dzięki programowi LXNM.
  • wtyczka netstatus: Inny monitor połączeń internetowych przeportowany z panelu dla gnome. Może działać tylko (choć nie musi) na Linuksie.
  • wtyczka volumealsa: Kontrola głośności przy użyciu ALSA. W LXPanel jest także inna wtyczka która nazywa się "volume" używająca interfejsu OSS. Tak więc nie jest ona dostępna tylko i wyłącznie dla systemów Linux.
  • batt plugin: Battery monitor using Linux ACPI. Currently it's Linux-only.

LXSession / LXSession Lite - menedżer sesji

  • DBus i HAL: HAL jest używany przy wylogowywaniu dla takich funkcji jak "Wstrzymanie systemu", "Hibernacja", "Restartuj", oraz "Wyłącz". Bez niego, LXSession będzie miał dostepną tylko opcję "Wyloguj".

LXTask - menedżer procesów

  • Pochodzi on z projektu menedżera procesów dla XFCE4, który znany jest z tego że działa tylko na Linuksie. Jeśli wiesz jak sprawić żeby działął także na innych platformach, napisałeś jakieś poprawki, proszę skontaktuj się z programistami, lub wyślij poprawki bezpośrednio na tracker.

Inne

  • Inne części LXDE powinny działać bez problemu na każdym systemie zgodnym z POSIX. Jeśli znajdziesz jakieś inne niekomptybilności, wyślij raport błędu na nasz tracker błędów.