Skillnad mellan versioner av "Arch Linux"

Från LXDE.org
Hoppa till: navigering, sök
(Ny sida: ==Install LXDE with pacman== Most of the latest LXDE packages are already in community repo of ArchLinux and maintained by trusted users. The rest might be found in AUR. (The compability o...)
 
(Configuration for locales and input method)
Rad 41: Rad 41:
 
  exec startlxde
 
  exec startlxde
  
==Configuration for locales and input method==
+
==Inställningar för lokalisering av tangentbord mm==
 
+
*GDM or KDM: Inga särskilda inställningar krävs.
*GDM or KDM: Setting locale is not needed.
+
*SLIM: I din ~/.xinitrc före "exec startlxde" lägger du följande:
*SLIM: put this in your ~/.xinitrc before "exec startlxde" to set locales.
+
  export LC_ALL=sv_SE.UTF-8
zh_TW.UTF-8 (traditional Chinese, Taiwan) is my locale, please replace it with yours.
+
  export LANGUAGE=sv_SE.UTF-8
  export LC_ALL=zh_TW.UTF-8
+
  export LANG=sv_SE.UTF-8
  export LANGUAGE=zh_TW.UTF-8
+
*WDM: ?
  export LANG=zh_TW.UTF-8
+
*XDM: ?
If you need to use input method, add those lines, too.
 
Please refer to the document of your input method. Here I use scim for example.
 
('''FIXME: Maybe we can use some im-switch compatible way here. Anyone know how to do it please fix this''')
 
export GTK_IM_MODULE=scim
 
export QT_IM_MODULE=xim
 
scim -d
 
  
 
==Minimal Arch + LXDE Installation==
 
==Minimal Arch + LXDE Installation==

Versionen från 10 januari 2009 kl. 00.02

Install LXDE with pacman

Most of the latest LXDE packages are already in community repo of ArchLinux and maintained by trusted users. The rest might be found in AUR. (The compability of LXDE and ArchLinux is guaranteed since the lead developer of this project is using Arch.)

Please add community repo to your /etc/pacman.conf. If you have problems, read the ArchWiki. There are nice articles for pacman. After adding community repository, execute the following commands with root access.

pacman -Sy lxde

For file managers to work, fam (file alteration monitor) daemon is needed. The beginner guide on ArchWiki also instruct the users to add "fam" to the DAEMON() list. However, fam is known to be quite problematic, and has some defects. So, it's gradually replaced by another "compatible" program, gamin in other distros. In Arch, however, fam is still used by default. Replacing fam with gamin is highly recommended. (Some users of other distros reported some problems with gamin, but it's quite rare.) The gamin package and fam are binary-compatible, and can be used interchangeably without breaking the system.

pacman -S gamin

Then you'll see some errors telling you that's it conflicts with fam. It's generally safe to remove fam once gamin is available. After you removed fam, don't forget to remove it from the DAEMON list in /etc/rc.conf. Gamin doesn't require a system-wide daemon running as root. It runs as general users on demand, so no manual configuration is needed.

If some latest packages are not available, search them in AUR with "yaourt".

Configuration for Login Managers

GDM or KDM

No manual configuration is needed. Just select LXDE from the available sessions listed by the display manager. If you don't see LXDE, restart your gdm or kdm, or reboot.

SLIM

With this display manager, some manual configuration is needed. Please refer to their official document and write your /etc/slim.conf and ~/.xinitrc. The command you should put in your ~/.xinitrc to start LXDE is:

exec startlxde

WDM

Anyone know how to use it please edit this.

XDM

Put this line at the end of "~/.xinitrc".

exec startlxde

Be sure to comment all other entries.

No display manager, use startx

Put this line at the end of "~/.xinitrc" or "/etc/X11/Xsession".

exec startlxde

Inställningar för lokalisering av tangentbord mm

  • GDM or KDM: Inga särskilda inställningar krävs.
  • SLIM: I din ~/.xinitrc före "exec startlxde" lägger du följande:
export LC_ALL=sv_SE.UTF-8
export LANGUAGE=sv_SE.UTF-8
export LANG=sv_SE.UTF-8
  • WDM: ?
  • XDM: ?

Minimal Arch + LXDE Installation

  • Install Arch base system with Arch core installer cd.
  • Then, turn on the community repository, and do this:
pacman -Sy lxde xorg

(FIXME: The list is not complete. Please add required packages to run X11 here.)