系統需求

来自LXDE.org
Lzy讨论 | 贡献2008年12月27日 (六) 08:19的版本 (新页面: ==系統需求== 相對於其他時下的桌面環境,LXDE 的系統需求是相當的低。只要是 1999 年以後的個人電腦,都能很順利的操作。 ==相容性== LXDE 可...)
(差异) ←上一版本 | 最后版本 (差异) | 下一版本→ (差异)
跳转至: 导航搜索

系統需求

相對於其他時下的桌面環境,LXDE 的系統需求是相當的低。只要是 1999 年以後的個人電腦,都能很順利的操作。

相容性

LXDE 可以安裝和運作在絕大部分的 POSIX 系統上的 X11 。Linux 是目前主要的支援平台;FreeBSD 也正在測試中,因此需要更多的幫助。如果您有成功的安裝 LXDE 在任何其他的系統上或者有任何關於它的程式補綴包(patch)請張貼在 issue tracker 上。

Linux 上每個元件的獨特功能(可以選擇與禁用)

LXDE 上的一些功能是只有 Linux 上才有的。您可以在編譯與設定選項時禁用他們,所以 LXDE 可以完整的在其他系統平台上編譯。透過 ./configure --help 您可以得到更多的相關資訊。

PCManFM - 檔案管理器

  • DBus 和 HAL(硬體抽象層):HAL 是對於隨插即用裝置使用批次掛載與管理的機制。
    • 這是可以被關閉的選項,但是 HAL 禁用的話,則 PCManFM 會無法掛載隨插即用裝置。(從 FreeBSD 6.0 開始已經支援 HAL

LXPanel - 桌面面板

  • netstat 插件:監控網際網路連線並且透過 LXNM 提供方便的無線網路連接。
  • netstatus 插件:從 gnome 面板上的網路狀態監控程式,不過可能是只支援 Linux。
  • volumealsa 插件:透過 ALSA 來控制聲音大小。在 LXPanel 裡,還有另一個聲音控制的插件叫"volume",則是使用 OSS 介面的。他不只只支援 Linux。
  • batt 插件:使用 Linux ACPI 的電池監控程式。通常只支援 Linux。

LXSession / LXSession Lite - 作業階段管理器

  • DBus 與 HAL:HAL 是使用在作業階段管理器中登出視窗的一些功能。例如:"暫停"、"休眠"、"重新開機"與"關機"。如果沒有它, LXSession 只能做"登出"而已。

LXTask - 工作管理員

  • 這是源自於 XFCE4 的工作管理員,已知只有支援 Linux 而已。如果您想知道如何修補與如何讓它運作在其他的系統上,請聯絡開發者或張貼程式補綴包(patch)在 issue tracker 上。

其他部份

其他關於 LXDE 的部份完美的執行在 POSIX 系統上是沒任何問題的。如果您發現有任何不相容問題時,請發送檔案錯誤報告至 bug tracker